4images Forum & Community
Welcome, Guest. Please login or register.
Did you miss your activation email?
August 18, 2018, 01:56:57 PM

Login with username, password and session length
Search:     Advanced search
Togle to toolbar
Translate this page with =>
Translate this page >
* Home Help Search Login Register
 
  Show Posts
Pages: [1] 2 3 4 5 6 » »»
1  4images Modifications / Modifikationen / Mods & Plugins (Releases & Support) / Re: Signature image v2.3 on: January 21, 2018, 09:32:26 AM
Hi.

I just changed my web server from PHP 5.6 to 7.0.
signature.php (v2.3) isn't working anymore.
The rest of 4images works fine.

Is there any "classic" trap I was falling into?

Otherwise, I post the exact erros.

Thanks,

... later ...

I noticed that ...

1
/signature/go

... works, but ...

1
/signature/signature.png

... creates this error:

1
2
3
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /4images/includes/db_mysql.php:37 Stack trace:
#0 /signature/signature.php(142): Db->__construct('<myhost>', '<myuser>', '<mypassword>', '<mydatabase>')
#1 {main} thrown in /4images/includes/db_mysql.php on line 37

<myhost>, <myuser>, <mypassword> and <mydatabase> are of course correct.

... later ...

I found the solution.

Changing this line in signature ...

1
2
3
...
  include(ROOT_PATH.'includes/db_mysqli.php');
...

(i.s.o. db_mysql.php)
2  4images Issues / Ausgaben / Installation, Update & Configuration / Re: Disable Registration on: March 13, 2017, 04:21:53 PM
So no button in ACP.
Thanks for the reply!
3  4images Issues / Ausgaben / Installation, Update & Configuration / Disable Registration on: March 13, 2017, 03:40:22 PM
Hi.

Easy question.
Should be trivial, but not found so far.

Is it possible to disable the possibility to register in a 4images gallery.
Not even activation via Admin or Email.
Simply no registration link at first page.

Is that possible?

Thanks,
4  4images Issues / Ausgaben / Discussion & Troubleshooting / Auto-Thumbnailer Bug? on: February 07, 2017, 06:22:34 PM
Hallo.

Habe soeben 4image 1.8 von 1.7.11 upgegraded und die Thumbnails neu erzeugt (jpg, 95% und 160 max. prop. Größe).

Die default Einstellung von max. Bildgröße von 160 funktioniert bei 900 Bildern, aber bei 1000 Bildern nicht mehr.
Ab 1000 Bildern ist die Bildgröße 100, nicht mehr 160 wie vorgegeben.
Die genaue Grenze habe ich jetzt nicht versucht herauszufinden.

Kann jemand das bestätigen?
Wenn ja, ein Bug, oder mache ich etwas falsch?

Gruß,
5  4images Issues / Ausgaben / Installation, Update & Configuration / Re: Archived download versions on: February 07, 2017, 10:07:37 AM
nein das denke ich eher nicht. Es sei denn das es Dir ein User zur Verfügung stellt.

Dann bitte ich 'mal hiermit drum. Es geht eher da drum mein Archiv zu vervollständigen.

Auch wenn ein Update (durch Modifikationen) manchmal schwierig ist, ist es aber besser immer die aktuelle Version einzubinden.

Gibt es etwas bestimmtes, auf was ich aufpassen muss wenn ich von 1.7.11 auf 1.8 upgrade?
Wird die Datenbank Struktur verändert?
Hatte in der Vergangenheit manchmal Probleme beim upgraden.
6  4images Issues / Ausgaben / Installation, Update & Configuration / Archived download versions on: February 03, 2017, 10:36:17 AM
Hallo.

Kann ich 1.7.12 & 1.7.13 noch downloaden?

Danke!
7  4images Modifications / Modifikationen / Mods & Plugins (Releases & Support) / Re: Signature image v2.3 on: November 06, 2015, 06:12:28 PM
Got it !!!

First ...
http://www.4homepages.de/forum/index.php?topic=24177.0
... then...
http://stackoverflow.com/questions/15358412/mysql-restore-db-syntax-error-in-procedure
... and finally ... I searched "TYPE = HEAP" and deleted it in signature.php, and that was it!
All like described in #465 above.
8  4images Modifications / Modifikationen / Mods & Plugins (Releases & Support) / Re: Signature image v2.3 on: October 30, 2015, 07:21:20 AM
For troubleshooting ... which MySQL and PHP versions do you have, which are known to be working with signature.php?

... later ....

What about .htaccess?
Do I need entries in .htaccess?

... later ...

Also ... putting "error_reporting(E_ALL);" in line 2 of signatures.php didn't help.
No extra output compared to the output without the debugging option.

Thanks,
9  4images Modifications / Modifikationen / Mods & Plugins (Releases & Support) / Re: Signature image v2.3 on: October 28, 2015, 10:01:43 AM
Saved the "signature.php" in ASCII (single byte) Encoding without BOM.
Thanks for the answer!
Didn't know that ASCII can be with or without BOM.

I checked the script. Notepad++ says ASCII (Encoding > Encode in ASCII).

Also ... nothing changed, except PHP (from 5.2 to 5.6 [both FastCGI]) and MySQL (from 5.1 to 5.6).
For me, it must be PHP or MySQL related.

What do you think?

BTW ... check my signature with multiple browser refreshs and have a look. Sometimes nothing shows (when the error hits) and sometimes it's a blank signature (without random picture on the left side).

When invoking the script manually (using the browser http://xxx/signature.php), it shows ...

1
2
3
4
5
6
7
8
9
10
An unexpected error occured. Please try again later.
An unexpected error occured. Please try again later.
An unexpected error occured. Please try again later.
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/gallery/includes/db_mysql.php:196) in /home/xxx/signature/signature.php on line 379
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/gallery/includes/db_mysql.php:196) in /home/xxx/signature/signature.php on line 380
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/gallery/includes/db_mysql.php:196) in /home/xxx/signature/signature.php on line 381
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/gallery/includes/db_mysql.php:196) in /home/xxx/signature/signature.php on line 382
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/gallery/includes/db_mysql.php:196) in /home/xxx/signature/signature.php on line 383
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/gallery/includes/db_mysql.php:196) in /home/xxx/signature/signature.php on line 384
‰PNG ...
10  4images Modifications / Modifikationen / Mods & Plugins (Releases & Support) / Re: Signature image v2.3 on: October 27, 2015, 09:01:43 PM
Another one ... my hoster changed from PHP 5.2 to 5.6 (FastCGI). Now i get the following message for signature.php:

1
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/gallery/includes/db_mysql.php:196) in /home/xxx/signature/signature.php on line 379

I read: http://www.4homepages.de/forum/index.php?topic=3378.0
However I don't see which of the 3 solutions could apply to signature.php.
I didn't change any (!) PHP code.

Which makes it even more strange ... sometimes, the signature shows, but without the random picture on the left side.
Could it be a mysql issue (I believe the hoster also changed this version recently to 5.6)?

Why is that and what can I do?

BTW ... the underlying 4images 1.7.11 gallery seems (!?) to work properly.

Thanks,
11  4images Issues / Ausgaben / Discussion & Troubleshooting / Re: Special characters replaced on: July 24, 2012, 11:18:35 PM
The MySQL database shows for table users "latin1_swedish_ci" as Collatation.
Could this be the reason?

Could someone please simulate an image (with special characters in filename as in OP) addition to the 4IG database.
Does this also happen on other 4IG installations?

Thanks,
12  4images Issues / Ausgaben / Discussion & Troubleshooting / Re: Special characters replaced on: July 22, 2012, 02:15:43 PM
I believe you refer to the upload using FTP. This works perfectly! The file arrives at the server exactly as it was sent. No changed characters.
The change of characters occurs by 4IG while adding the picture!
13  4images Issues / Ausgaben / Discussion & Troubleshooting / Special characters replaced on: July 22, 2012, 10:44:51 AM
Hi.

When I upload this file ...
paransq[]-accol{}-number#-paranround().jpg
... I get ...
paransq__-accol__-number_-paranround__.jpg
... after adding the image ("Check new images").

How can I tell 4IG (1.7.10) to leave the filename's special characters untouched?

Thanks,

--

Hallo.

Wenn ich diese Datei ...
paransq[]-accol{}-number#-paranround().jpg
... mittels FTP auf den Server lade und es dann mit der 4IG einfüge ("Check new images"), macht 4IG aus der Datei ...
paransq__-accol__-number_-paranround__.jpg

Wie kann ich 4IG (1.7.10) die Datei nicht umzubenennen?

Gruß,
14  4images Issues / Ausgaben / Installation, Update & Configuration / Re: "Clear Cache" gone! on: November 13, 2009, 08:10:07 AM
hi,

upload clear_cache.php from original downloaded 4images1.7.7.zip into admin/plugins/
reloal your ACP. now it should apear again..

Yes, it was gone! Thanks. Works now again!

However I'd like to know how this was possible ?!?!

- There there any ACP user related interaction which might trigger to delete this file?
- Or perhaps manipulating the $cache_path variable in config.php ... does this possibly delete clear_cache.php?

Thanks
15  4images Issues / Ausgaben / Installation, Update & Configuration / "Clear Cache" gone! on: November 12, 2009, 07:09:18 PM
Hi.

For some reason, "Clear Cache" link doesn't show anymore under PlugIns in the ACP.

I didn't change anything the the config.php

Never seen this before. Why is that? Any ideas?

I use 4images 1.7.7.

Is it possible thatthis has to do something with a database, which went corrupt (shouldn't actually ...)?

I'm running out of ideas!

Thanks,
Pages: [1] 2 3 4 5 6 » »»
Powered by MySQL Powered by PHP Powered by SMF | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.061 seconds with 18 queries.
Post your comments here